const regex = /^[\w,\s-]+\.(jpg|jpeg|png|gif|pdf)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w,\\s-]+\\.(jpg|jpeg|png|gif|pdf)$', 'gm')
const str = `resource.png
resource.zip
resource.pdf
resource.
resource.jpg
resource.jpeg
.pdf
r\$esource.pdf
// You can show origina post on albertcolom.com/blog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}