import re
regex = re.compile(r"^[\w,\s-]+\.(jpg|jpeg|png|gif|pdf)$", flags=re.MULTILINE)
test_str = ("resource.png\n"
"resource.zip\n"
"resource.pdf\n"
"resource.\n"
"resource.jpg\n"
"resource.jpeg\n"
".pdf\n"
"r$esource.pdf\n\n"
"// You can show origina post on albertcolom.com/blog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")