re = /^[\w,\s-]+\.(jpg|jpeg|png|gif|pdf)$/m
str = 'resource.png
resource.zip
resource.pdf
resource.
resource.jpg
resource.jpeg
.pdf
r$esource.pdf
// You can show origina post on albertcolom.com/blog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end