using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}])[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}a-zA-Z-,.。、!!??@@・'’0-9 ]+$";
string input = @"パイソンが得意です
pythonが得意です
I'm good at python.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}