use strict;
my $str = 'パイソンが得意です
pythonが得意です
I\'m good at python.';
my $regex = qr/^(?=.*[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}])[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}a-zA-Z-,.。、!!??@@・'’0-9 ]+$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}