import re
regex = re.compile(r"^(?=.*[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}])[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}a-zA-Z-,.。、!!??@@・'’0-9 ]+$", flags=re.MULTILINE | re.UNICODE)
test_str = ("パイソンが得意です\n"
"pythonが得意です\n"
"I'm good at python.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")