import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[\\p{Script=Hiragana}\\p{Script=Katakana}\\p{Script=Han}])[\\p{Script=Hiragana}\\p{Script=Katakana}\\p{Script=Han}a-zA-Z-,.。、!!??@@・'’0-9 ]+$";
final String string = "パイソンが得意です\n"
+ "pythonが得意です\n"
+ "I'm good at python.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}