const regex = /^(?=.*[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}])[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}a-zA-Z-,.。、!!??@@・'’0-9 ]+$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[\\p{Script=Hiragana}\\p{Script=Katakana}\\p{Script=Han}])[\\p{Script=Hiragana}\\p{Script=Katakana}\\p{Script=Han}a-zA-Z-,.。、!!??@@・\'’0-9 ]+$', 'gmu')
const str = `パイソンが得意です
pythonが得意です
I'm good at python.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}