re = /^(?=.*[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}])[\p{Script=Hiragana}\p{Script=Katakana}\p{Script=Han}a-zA-Z-,.。、!!??@@・'’0-9 ]+$/m
str = 'パイソンが得意です
pythonが得意です
I\'m good at python.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end