#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\r?\n"
Local $sString = "Process Owner : fred_smith@yahoo.com" & @CRLF & _
"Vendor Name : YAHOO (RPE0001234)"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)