const regex = new RegExp('\\r?\\n', 'gm')
const str = `Process Owner : fred_smith@yahoo.com
Vendor Name : YAHOO (RPE0001234)`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);