import re
regex = re.compile(r"\r?\n", flags=re.MULTILINE)
test_str = ("Process Owner : fred_smith@yahoo.com\n"
"Vendor Name : YAHOO (RPE0001234)")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)