use strict;
my $str = 'Process Owner : fred_smith@yahoo.com
Vendor Name : YAHOO (RPE0001234)';
my $regex = qr/\r?\n/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";