$re = '/\r?\n/m';
$str = 'Process Owner : fred_smith@yahoo.com
Vendor Name : YAHOO (RPE0001234)';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;