# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*([\d\s]*)(.*)//gm;t' <<< "255 255 255 hello world
10 10 10 some text here
nothing here...
10 10 10
"