re = /\s*([\d\s]*)(.*)/m
str = '255 255 255 hello world
10 10 10 some text here
nothing here...
10 10 10
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result