use strict;
my $str = '255 255 255 hello world
10 10 10 some text here
nothing here...
10 10 10
';
my $regex = qr/\s*([\d\s]*)(.*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";