using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([\d\s]*)(.*)";
string substitution = @"";
string input = @"255 255 255 hello world
10 10 10 some text here
nothing here...
10 10 10
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}