// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*([\d\s]*)(.*)").unwrap();
let string = "255 255 255 hello world
10 10 10 some text here
nothing here...
10 10 10
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}