#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*([\d\s]*)(.*)"
Local $sString = "255 255 255 hello world" & @CRLF & _
" 10 10 10 some text here" & @CRLF & _
"nothing here..." & @CRLF & _
"10 10 10" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)