package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+?(([0-9]){1,2})[- .]|\+?([0-9]{1,15}))?((((\(?([0-9]){2,3}\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\s*(?:#|x\.?|ext\.?|ex\.)\s*(\d+\s*?))?$`)
var str = `1 800 888 8078
+1 402.536.4184 ext 8862088
+91.986.964.4357
+972546790128
+972(0)74-745-4014`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}