re = /^(\+?(([0-9]){1,2})[- .]|\+?([0-9]{1,15}))?((((\(?([0-9]){2,3}\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\s*(?:#|x\.?|ext\.?|ex\.)\s*(\d+\s*?))?$/m
str = '1 800 888 8078
+1 402.536.4184 ext 8862088
+91.986.964.4357
+972546790128
+972(0)74-745-4014'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end