const regex = /^(\+?(([0-9]){1,2})[- .]|\+?([0-9]{1,15}))?((((\(?([0-9]){2,3}\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\s*(?:#|x\.?|ext\.?|ex\.)\s*(\d+\s*?))?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+?(([0-9]){1,2})[- .]|\\+?([0-9]{1,15}))?((((\\(?([0-9]){2,3}\\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\\s*(?:#|x\\.?|ext\\.?|ex\\.)\\s*(\\d+\\s*?))?$', 'mg')
const str = `1 800 888 8078
+1 402.536.4184 ext 8862088
+91.986.964.4357
+972546790128
+972(0)74-745-4014`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}