// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+?(([0-9]){1,2})[- .]|\+?([0-9]{1,15}))?((((\(?([0-9]){2,3}\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\s*(?:#|x\.?|ext\.?|ex\.)\s*(\d+\s*?))?$").unwrap();
let string = "1 800 888 8078
+1 402.536.4184 ext 8862088
+91.986.964.4357
+972546790128
+972(0)74-745-4014";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}