import Foundation
let pattern = ##"^(\+?(([0-9]){1,2})[- .]|\+?([0-9]{1,15}))?((((\(?([0-9]){2,3}\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\s*(?:#|x\.?|ext\.?|ex\.)\s*(\d+\s*?))?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 800 888 8078
+1 402.536.4184 ext 8862088
+91.986.964.4357
+972546790128
+972(0)74-745-4014
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)