import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+?(([0-9]){1,2})[- .]|\\+?([0-9]{1,15}))?((((\\(?([0-9]){2,3}\\)?)[- .]){1,2}([0-9]{4,10}))|([0-9]{10}))s*(?:\\s*(?:#|x\\.?|ext\\.?|ex\\.)\\s*(\\d+\\s*?))?$";
final String string = "1 800 888 8078\n"
+ "+1 402.536.4184 ext 8862088\n"
+ "+91.986.964.4357\n"
+ "+972546790128\n"
+ "+972(0)74-745-4014";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}