#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d{1,2}[-\/]\d{1,2}\s?[\-\/]\s?\d{4}"
Local $sString = "tetsts kmasjdkjsad kajsdkjasdkj kjadjaksd 45-12-2020 lkdlksldksd" & @CRLF & _
"asd sjdjska 10-11-1989 ksjdkds 1-11-1456" & @CRLF & _
"skdasdsa" & @CRLF & _
"dasdlkj kajsd kjaksdj ksadjk jsadkdj a 1/1 - 1899"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)