import Foundation
let pattern = #"\d{1,2}[-\/]\d{1,2}\s?[\-\/]\s?\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
tetsts kmasjdkjsad kajsdkjasdkj kjadjaksd 45-12-2020 lkdlksldksd
asd sjdjska 10-11-1989 ksjdkds 1-11-1456
skdasdsa
dasdlkj kajsd kjaksdj ksadjk jsadkdj a 1/1 - 1899
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)