// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}[-\/]\d{1,2}\s?[\-\/]\s?\d{4}").unwrap();
let string = "tetsts kmasjdkjsad kajsdkjasdkj kjadjaksd 45-12-2020 lkdlksldksd
asd sjdjska 10-11-1989 ksjdkds 1-11-1456
skdasdsa
dasdlkj kajsd kjaksdj ksadjk jsadkdj a 1/1 - 1899";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}