re = /\d{1,2}[-\/]\d{1,2}\s?[\-\/]\s?\d{4}/m
str = 'tetsts kmasjdkjsad kajsdkjasdkj kjadjaksd 45-12-2020 lkdlksldksd
asd sjdjska 10-11-1989 ksjdkds 1-11-1456
skdasdsa
dasdlkj kajsd kjaksdj ksadjk jsadkdj a 1/1 - 1899'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result