# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.{4}\K.+//gm;t' <<< "V307G5C
V307G57
V307G5X
V307G54
V307G57
V307G5Y
V307G58
V307G5L
V307G56
V307G5M"