re = /^.{4}\K.+/m
str = 'V307G5C
V307G57
V307G5X
V307G54
V307G57
V307G5Y
V307G58
V307G5L
V307G56
V307G5M'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result