import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.{4}\\K.+";
final String string = "V307G5C\n"
+ "V307G57\n"
+ "V307G5X\n"
+ "V307G54\n"
+ "V307G57\n"
+ "V307G5Y\n"
+ "V307G58\n"
+ "V307G5L\n"
+ "V307G56\n"
+ "V307G5M";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}