using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{4}\K.+";
string substitution = @"";
string input = @"V307G5C
V307G57
V307G5X
V307G54
V307G57
V307G5Y
V307G58
V307G5L
V307G56
V307G5M";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}