# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.{4}\K.+"
test_str = ("V307G5C\n"
"V307G57\n"
"V307G5X\n"
"V307G54\n"
"V307G57\n"
"V307G5Y\n"
"V307G58\n"
"V307G5L\n"
"V307G56\n"
"V307G5M")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.