use strict;
my $str = 'V307G5C
V307G57
V307G5X
V307G54
V307G57
V307G5Y
V307G58
V307G5L
V307G56
V307G5M';
my $regex = qr/^.{4}\K.+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";