#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.{4}\K.+"
Local $sString = "V307G5C" & @CRLF & _
"V307G57" & @CRLF & _
"V307G5X" & @CRLF & _
"V307G54" & @CRLF & _
"V307G57" & @CRLF & _
"V307G5Y" & @CRLF & _
"V307G58" & @CRLF & _
"V307G5L" & @CRLF & _
"V307G56" & @CRLF & _
"V307G5M"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)