# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\(\[)\*\b([^*]*)\b\*(\]\))/$1$2$3/gm;t' <<< "* <release_note_text>([*XXXBUGS-12345*])."