$re = '/(\(\[)\*\b([^*]*)\b\*(\]\))/m';
$str = '* <release_note_text>([*XXXBUGS-12345*]).';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;