#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\(\[)\*\b([^*]*)\b\*(\]\))"
Local $sString = "* <release_note_text>([*XXXBUGS-12345*])."
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)