re = /(\(\[)\*\b([^*]*)\b\*(\]\))/m
str = '* <release_note_text>([*XXXBUGS-12345*]).'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result