// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\(\[)\*\b([^*]*)\b\*(\]\))").unwrap();
let string = "* <release_note_text>([*XXXBUGS-12345*]).";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}