package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\(\[)\*\b([^*]*)\b\*(\]\))`)
var str = `* <release_note_text>([*XXXBUGS-12345*]).`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}