const regex = /(\(\[)\*\b([^*]*)\b\*(\]\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(\\[)\\*\\b([^*]*)\\b\\*(\\]\\))', 'gm')
const str = `* <release_note_text>([*XXXBUGS-12345*]).`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);