#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*?0.*0)[02aQ][a-zA-Z0-9$]+[Sd]$"
Local $sString = "(1). Starting with 0/2/a/Q." & @CRLF & _
"(2). Must end with S/d." & @CRLF & _
"(3). Must contain at least two 0." & @CRLF & _
"(5). Only contain Alphanumeric character and the only special character '$' (Dollar sign)." & @CRLF & _
"" & @CRLF & _
"0abcde0fS" & @CRLF & _
"200abcd" & @CRLF & _
"" & @CRLF & _
"x00s" & @CRLF & _
"0abcdefS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")