import Foundation
let pattern = #"^(?=.*?0.*0)[02aQ][a-zA-Z0-9$]+[Sd]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(1). Starting with 0/2/a/Q.
(2). Must end with S/d.
(3). Must contain at least two 0.
(5). Only contain Alphanumeric character and the only special character '$' (Dollar sign).
0abcde0fS
200abcd
x00s
0abcdefS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)