import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?0.*0)[02aQ][a-zA-Z0-9$]+[Sd]$";
final String string = "(1). Starting with 0/2/a/Q.\n"
+ "(2). Must end with S/d.\n"
+ "(3). Must contain at least two 0.\n"
+ "(5). Only contain Alphanumeric character and the only special character '$' (Dollar sign).\n\n"
+ "0abcde0fS\n"
+ "200abcd\n\n"
+ "x00s\n"
+ "0abcdefS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}