use strict;
my $str = '(1). Starting with 0/2/a/Q.
(2). Must end with S/d.
(3). Must contain at least two 0.
(5). Only contain Alphanumeric character and the only special character \'$\' (Dollar sign).
0abcde0fS
200abcd
x00s
0abcdefS';
my $regex = qr/^(?=.*?0.*0)[02aQ][a-zA-Z0-9$]+[Sd]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}