# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.*?0.*0)[02aQ][a-zA-Z0-9$]+[Sd]$"
test_str = ("(1). Starting with 0/2/a/Q.\n"
"(2). Must end with S/d.\n"
"(3). Must contain at least two 0.\n"
"(5). Only contain Alphanumeric character and the only special character '$' (Dollar sign).\n\n"
"0abcde0fS\n"
"200abcd\n\n"
"x00s\n"
"0abcdefS")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.