$re = '/^(?=.*?0.*0)[02aQ][a-zA-Z0-9$]+[Sd]$/m';
$str = '(1). Starting with 0/2/a/Q.
(2). Must end with S/d.
(3). Must contain at least two 0.
(5). Only contain Alphanumeric character and the only special character \'$\' (Dollar sign).
0abcde0fS
200abcd
x00s
0abcdefS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);